Installation de paquets Python avec Pip : résoudre l'erreur Could not find a version that satisfies the requirement

Installation de paquets Python avec Pip : résoudre l'erreur Could not find a version that satisfies the requirement Le erreur se produit lorsque votre gestionnaire de paquets n'arrive pas à communiquer avec le serveur qui contient les paquets. Voici comment la corriger.

Lorsque vous utilisez le gestionnaire de paquets PIP, une tentative d'installation d'un paquet peut conduire à l'affichage du message suivant : "Could not find a version that satisfies the requirement". Cette erreur se produit lorsque votre gestionnaire de paquets n'arrive pas à communiquer avec le serveur qui contient les paquets. Cela est dû à une modification de Python dans la gestion du protocole de sécurité (à voir également le tutoriel : Comment mettre à jour son environnement Python dans Windows ?).

Python a en effet modifié le protocole de sécurité pour les serveurs hébergeant les paquets PIP. Le protocole utilisé est maintenant TLS 1.2. Les installations de Python utilisant une version antérieure de TLS ne peuvent plus installer ou mettre à jour de paquets. Pour les utilisateurs de Mac et Linux, les procédures ne sont pas les mêmes pour mettre à jour PIP.

Si vous utilisez une version de Mac OSX antérieure à la version 10.13, il faut avoir au minimum la version 9.0.3 de Python pour pouvoir utiliser le protocole TLS 1.2. La commande suivante va mettre à jour votre version de PIP :

curl https://bootstrap.pypa.io/get-pip.py | python

Si vous utilisez un système Linux basé sur Debian, comme Ubuntu ou Linux Mint, vous devez effectuer la mise à jour de votre gestionnaire de paquets, "apt-get" puis mettre à jour le paquet lié à PIP :

apt-get update && apt-get upgrade python-pip

Si vous travaillez à partir d'un système d'exploitation basé sur Red-Hat, comme Fedora ou bien CentOS, la mise à jour de PIP doit être effectuée avec le gestionnaire de paquets YUM.

yum update python-pip

À partir de la version 7 de Red Hat, le nom du paquet a été modifié :

yum update python2-pip

Une fois pip mis à jour, il est également recommandé de mettre à jour les utilitaires d'installations fournis avec Python. Cela peut-être fait à l'aide d'une commande et de pip.

pip install --upgrade setuptools

Autour du même sujet

Installation de paquets Python avec Pip : résoudre l'erreur Could not find a version that satisfies the requirement
Installation de paquets Python avec Pip : résoudre l'erreur Could not find a version that satisfies the requirement

Lorsque vous utilisez le gestionnaire de paquets PIP, une tentative d'installation d'un paquet peut conduire à l'affichage du message suivant : "Could not find a version that satisfies the requirement". Cette erreur se produit lorsque...