Installer une librairie Python avec Pip : corriger l'erreur [SSL: TLSV1_ALERT_PROTOCOL_VERSION]

Pour fonctionner correctement, le gestionnaire de paquets Python PIP utilise le protocole TLS afin de communiquer avec les dépôts contenant les paquets. L'erreur "[SSL: TLSV1_ALERT_PROTOCOL_VERSION]" se produit lorsque vous utilisez une version non supportée du protocole TLS.

Pour des raisons de sécurité, le gestionnaire de paquet PIP ne fonctionne qu'avec le protocole SSL en version 1.2 au minimum. Si vous utilisez une version plus ancienne du protocole, vous aurez le message d'erreur indiqué plus haut. Pour résoudre ce problème, vous devez mettre à jour PIP. Pour mettre à jour PIP, il ne faut surtout pas utiliser les commandes de PIP directement. Il ne peut pas se mettre à jour lui-même. Il est nécessaire d'utiliser dans un premier temps la commande "curl". Elle va télécharger le script qui met à jour PIP. Avec l'opérateur "|" on peut directement exécuter le script téléchargé avec la commande "Python". Si vous ne travaillez pas dans un environnement virtuel, vous devrez alors soit lancer l'invite de commande en mode administrateur dans le cas où vous travaillez avec Windows, soit utiliser la commande "sudo Python" à la place de "Python" si vous êtes sur un ordinateur équipé d'un système Mac ou Linux.

curl https://bootstrap.pypa.io/get-pip.py | python

Si vous travaillez avec l'environnement de développement PyCharm, alors l'IDE utilise un système d'environnement virtuel pour faire tourner Python. Vous devez donc démarrer l'environnement virtuel avant de lancer la commande mise à jour.

# Démarre l'environnement virtuel
source ./venv/bin/activate
# Lance la mise à jour PIP
curl https://bootstrap.pypa.io/get-pip.py | python

Une fois la mise à jour effectuée, vous devrez redémarrer votre instance de PyCharm. Vous pourrez vérifier la version dans les préférences du logiciel.

Autour du même sujet