Plugin des services Google : corriger l'erreur de conflit de version

Lorsque vous développez votre application pour Android, vous avez la possibilité d'intégrer les services de Google. Il faut pour cela utiliser le plugin "Google Services". Il permet d'utiliser les API des différents services de Google, comme Maps ou Play. Ce plugin inclut également Firebase, une plateforme pour aider les développeurs à concevoir la partie "Serveur" de leur application. L'erreur de conflit de version liée à ce plugin est simple à résoudre.

Lorsque vous installez ce plugin dans votre projet, vous devez modifier le fichier de construction du projet, "build.gradle". Vous devez ajouter une directive qui intègre le plugin.

apply plugin: 'com.google.gms.google-services'

Vous devez ensuite intégrer les librairies donc vous avez besoin, une par une en indiquant pour chacune une version (avant la version 3 de Gradle, le mot-clé "compile" remplace le mot-clé "implementation").

implementation 'com.google.firebase:firebase-messaging:10.0.1'
implementation 'com.google.android.gms:play-services-maps:11.0.4'

L'erreur se produit si les versions que vous intégrez ne sont pas les mêmes. Si vous utilisez le plugin dans une version antérieure à la version 4.1.0, le numéro de version doit être le même pour chaque librairie utilisée.

implementation 'com.google.firebase:firebase-messaging:11.0.4'
implementation 'com.google.android.gms:play-services-maps:11.0.4'

À partir de la version 4.1.0, le plugin "Google Services" autorise l'utilisation de versions différentes pour chaque librairie. Vous n'aurez donc plus ce message d'erreur. Pour mettre à jour la librairie, modifiez la version de la librairie incluse dans la directive "dependencies" dans le fichier "build.gradle".

dependencies {
  classpath 'com.android.tools.build:gradle:3.2.0'
  classpath 'com.google.gms:google-services:4.2.0' //Version à mettre à jour
}

Vous pouvez voir quelle est la dernière version disponible pour le plugin "Google Services" en regardant le repository Maven à cette adresse : https://mvnrepository.com/artifact/com.google.gms/google-services?repo=bt-android-tools.

Autour du même sujet

Android

Plugin des services Google : corriger l'erreur de conflit de version
Plugin des services Google : corriger l'erreur de conflit de version

Lorsque vous développez votre application pour Android, vous avez la possibilité d'intégrer les services de Google. Il faut pour cela utiliser le plugin "Google Services". Il permet d'utiliser les API des différents services de Google, comme Maps ou...