Comment résoudre l'erreur Configuration on demand is not supported by the current version of the Android Gradle plugin ?

L'outil de construction de projet Gradle peut être paramétré de manière précise pour s'adapter à vos besoins. Il peut utiliser le mode "configuration à la demande". Ce mode est utile pour des projets fonctionnant avec plusieurs modules. Lorsqu'il est activé, Gradle ne compile que les modules nécessaires pour la tâche que vous avez demandée, afin de vous faire gagner du temps. Si le message d'erreur "Configuration on demand is not supported by the current version of the Android Gradle plugin" apparaît, alors cette possibilité n'est pas supportée par la version de Gradle que vous utilisez, vous devez la désactiver.

Il y a deux modifications à faire pour désactiver la configuration à la demande. La première se situe dans les fichiers de votre projet. Vous devez ouvrir les deux fichiers "gradle.properties". L'un se situe à la racine du dossier de votre projet. L'autre est dans le dossier "${HOME}/.gradle/gradle.properties". Ouvrez les deux fichiers et supprimez les lignes où figure la propriété "org.gradle.configureondemand".

La deuxième modification est dans votre logiciel Android Studio. Il faut désactiver la propriété de configuration à la demande. L'emplacement de la case à cocher diffère selon le système d'exploitation que vous utilisez. Si vous travaillez avec les systèmes d'exploitation Windows ou Linux, vous devez aller dans le menu "File", puis "Settings". Dans l'écran des paramètres, sélectionnez dans la colonne de gauche le menu "Build, Execution, Deployment", puis le sous-menu "Compiler". Décochez alors la case à cocher "configure on demand".

Si vous travaillez sur un Mac, l'écran des paramètres se trouve directement dans le menu "Preferences". Suivez ensuite la même démarche qu'avec Windows et Linux.

Vous pouvez relancer la construction de votre projet et le message d'erreur ne s'affichera plus.

Autour du même sujet

Android

Comment résoudre l'erreur Configuration on demand is not supported by the current version of the Android Gradle plugin ?
Comment résoudre l'erreur Configuration on demand is not supported by the current version of the Android Gradle plugin ?

L'outil de construction de projet Gradle peut être paramétré de manière précise pour s'adapter à vos besoins. Il peut utiliser le mode "configuration à la demande". Ce mode est utile pour des projets fonctionnant avec plusieurs modules. Lorsqu'il est...