Comment corriger l'erreur ERROR in Cannot find module 'node-sass' dans Angular ?

Le framework Angular utilise de nombreux modules extérieurs pour fonctionner. Il a notamment besoin du module "Node-SASS". Sass est un préprocesseur CSS. Les préprocesseurs permettent d'ajouter des fonctionnalités supplémentaires pour générer des feuilles de styles plus compliqués avec moins de code. Ils permettent notamment d'insérer des variables ou d'utiliser des boucles, des éléments qui ne sont pas utilisables dans un simple fichier CSS. Si le module n'est pas présent sur votre ordinateur, comme l'indique le message d'erreur, alors il faut l'installer.

De la même manière que le framework Angular, vous pouvez installer la librairie "Node-SASS" avec le gestionnaire de paquets intégré à Node.js, npm. La commande "npm install" suivie du nom du paquet permet d'effectuer l'installation. Nous vous conseillons d'utiliser l'option "--save-dev". Cette option indique que ce paquet ne sera installé que pour le développement de votre application, et pas pour la version de production. Comme le préprocesseur Sass n'est utile que lorsque vous créez du code, l'utilisateur final n'en aura pas besoin. Pour être sûr que la librairie s'installe correctement, il est conseillé d'utiliser un compte administrateur sur votre machine. Vous pouvez sous Linux utiliser le préfixe "sudo". Sinon, la commande "npm" fournit l'option "--unsafe-perm". Avec cette option, il n'y aura pas de changement de permission lorsque vous lancerez l'installation. Cette option produit le même effet qu'une installation depuis l'utilisateur "root" et garantit la bonne installation du paquet.

//En tant que root
sudo npm install --save-dev node-sass
//Avec l'option "--unsafe-perm"
npm install --save-dev --unsafe-perm node-sass
Autour du même sujet

JavaScript