Comment corriger le problème flutter run: No connected devices ?

Flutter est un framework créé par Google. Il permet de développer des applications fonctionnant sur les 2 principales plateformes mobiles, Android et iOS, à partir d'une même base de code. Lorsque vous avez commencé à travailler sur votre projet, la commande "flutter run" permet de le lancer pour voir le rendu. Si vous obtenez le message d'erreur "No connected devices", alors il s'agit d'un problème lié à la connexion avec le SDK d'Android.

Flutter a besoin, pour lancer votre application, d'un SDK d'Android. Pour le lui fournir, il y a 2 possibilités : s'appuyer sur l'environnement de développement Android Studio, qui fournit un émulateur du système Android, ou bien connecter à l'ordinateur un appareil utilisant ce système d'exploitation.

Si vous avez choisi d'utiliser Android Studio, il faut au préalable avoir activé l'accélération matérielle sur votre ordinateur. C'est le cas pour la plupart des ordinateurs actuels, mais pour être sûr, vous devez vérifier ce réglage. Il est situé dans les paramètres du BIOS au démarrage de l'ordinateur. Après avoir installé Android Studio, lancez-le et rendez-vous dans le menu "Outils", "Android" et "AVD Manager". Cliquez ensuite sur le bouton "Créer un appareil virtuel". Choisissez la définition que vous souhaitez utiliser et cliquez sur "Suivant". Sélectionnez ensuite une ou plusieurs versions d'Android, celles que vous souhaitez émuler. Il est conseillé de choisir une image de type "x86" ou "x86_64". Dans la section suivante, allez sur la partie "Performance de l'émulation" et sélectionnez "Hardware - GLES 2.0". Cette option activera l'accélération matérielle. Cliquez ensuite sur "Terminer" pour que l'émulateur soit créé. Retournez ensuite dans la gestion des appareils virtuels et cliquez sur le bouton "Démarrer" dans la barre d'outils pour lancer l'émulateur. La commande "flutter run" affichera ensuite votre application dans l'émulateur. Il est également possible de démarrer l'émulateur avec l'application directement depuis l'écran de développement d'Android Studio, grâce à un bouton indiquant l'émulateur situé dans la barre d'outils placée au-dessus de la page de code.

Si vous souhaitez utiliser un de vos appareils intégrant le système Android, il faut d'abord vérifier qu'il utilise une version d'Android égale à la version 4.1 ou plus récente. Dans les paramètres de votre appareil, rendez-vous dans les Options pour développeurs et activez le débogage USB. Branchez ensuite l'appareil à votre ordinateur. S'il vous le demande, autorisez l'ordinateur à accéder à votre appareil. Rendez-vous ensuite dans le terminal (ou l'invite de commande pour Windows) et utilisez la commande "flutter devices" afin de vérifier que Flutter reconnaît bien votre appareil. La commande "flutter run" va vous permettre de lancer votre application. Notez que par défaut, Flutter va utiliser la version d'Android placée là où les outils ADB ont été installés. Si vous souhaitez utiliser une autre version, vous devrez remplacer le contenu de la variable d'environnement "ANDROID_HOME" par le répertoire dans lequel est installée la version choisie.

Autour du même sujet

Android