Résoudre l'erreur ':app:debugCompileClasspath'. Could not resolve com.android.support:appcompat-v7:26.1.0.

Le message d'erreur "Could not resolve com.android.support:appcompat-v7:26.1.0." indique un problème dans la construction de votre application Android. Le moteur de construction Gradle n'a pas réussi à trouver la librairie AppCompat dans la version demandée. Cette erreur peut-être due à une simple erreur de paramétrage de Gradle. Si ce n'est pas le cas, alors il faut modifier les paramètres de construction du projet.

Cette erreur peut être simplement due au fait que Gradle est configuré pour travailler en mode offline. Si c'est le cas, il ne télécharge pas de ressources additionnelles et dans votre cas ne télécharge pas la librairie en question. Pour résoudre ce problème, il faut ouvrir les paramètres de Gradle. Ouvrez le menu "File" puis "Settings". Dans la colonne de gauche, sélectionnez l'option "Build, Execution, Deployment puis cliquez sur "Gradle". Décochez l'option "Offline work" pour désactiver cette option puis relancez la construction du projet.

Si l'option était déjà décochée ou que cela ne résout pas votre problème, alors il faut contrôler les fichiers de construction de votre projet. Ouvrez le fichier "build.gradle" de votre application. Dans la section "repositories", vérifiez que le dépôt Google de Maven est bien présent. Selon votre version de Gradle, vous devez trouver soit l'URL du dépôt de Google (https://maven.google.com), soit la fonction "google()".

Dans les dépendances (situées dans la section "dependencie"), vérifiez que la librairie est incluse dans la bonne version :

dependencies {
    ...
    implementation "com.android.support:appcompat-v7:26.1.0"
}

La dernière vérification est la version minimum du SDK requise. Vérifiez dans la documentation de la librairie la version souhaitée et dans votre fichier build.gradle, modifiez la variable "minSdkVersion". Si cette variable n'existe pas, alors il faut changer l'attribut "android:minSdkVersion" dans votre manifeste de déclaration de l'application.

Après toutes ces modifications, relancez la construction de votre projet pour valider les changements.

Autour du même sujet

Résoudre l'erreur ':app:debugCompileClasspath'. Could not resolve com.android.support:appcompat-v7:26.1.0.
Résoudre l'erreur ':app:debugCompileClasspath'. Could not resolve com.android.support:appcompat-v7:26.1.0.

Le message d'erreur "Could not resolve com.android.support:appcompat-v7:26.1.0." indique un problème dans la construction de votre application Android. Le moteur de construction Gradle n'a pas réussi à trouver la librairie AppCompat dans la version...