Comment résoudre l'erreur Failed to resolve: com.android.support:appcompat ?

L'outil de construction Gradle utilise de nombreuses dépendances pour construire votre projet. Il peut rencontrer des problèmes lors de l'inclusion de librairies de support. Ce sont les librairies dont le préfixe commence par "com.android.support". Si vous obtenez le message "Failed to resolve" suivi d'une librairie contenant ce préfixe, alors vous devez ajouter un dépôt supplémentaire dans le fichier paramétrant la construction de votre application.

Ouvrez le fichier "build.gradle" situé à la racine du projet. C'est en lisant ce fichier que Gradle construit l'application. Pour pouvoir utiliser correctement les librairies de support, vous devez inclure le dépôt Maven de Google. Ajoutez pour cela le dépôt dans la section "repositories" :

repositories {
    …
    google() //Cette fonction va inclure directement le dépôt Maven de Google
}

Vous avez la possibilité d'utiliser des variables pour inclure des librairies. Par exemple l'ajout du caractère "+" permet de définir une version minimum à la place d'une version précise. Il est cependant préférable d'indiquer une version précise pour votre projet.

//Exemple d'inclusion avec une variable
implementation 'com.android.support:appcompat-v7:27.+'
//Il vaut mieux inclure une version spécifique
implementation 'com.android.support:appcompat-v7:27.0.0'

Si vous travaillez avec une version de Gradle antérieure à la version 3, l'inclusion du dépôt Maven de Google ne se fait pas de la même façon. La fonction "google()" n'existant pas encore, vous devez appeler la fonction "maven()" et indiquer l'URL du dépôt de Google dans le paramètre "url".

repositories {
    …
    maven {
        url "https://maven.google.com"
    } //Cette fonction va inclure directement le dépôt Maven de Google
}

Avant la version 3, les librairies sont importées avec le mot-clé "compile" :

compile 'com.android.support:appcompat-v7:27.0.0'

Autour du même sujet

Comment résoudre l'erreur Failed to resolve: com.android.support:appcompat ?
Comment résoudre l'erreur Failed to resolve: com.android.support:appcompat ?

L'outil de construction Gradle utilise de nombreuses dépendances pour construire votre projet. Il peut rencontrer des problèmes lors de l'inclusion de librairies de support. Ce sont les librairies dont le préfixe commence par "com.android.support". Si...