Comment corriger l'erreur Program type already present: android.support.design.widget.CoordinatorLayout$Behavior

La gestion des dépendances dans un projet Android est une partie importante. Il faut faire attention lorsque l'on met à jour ses dépendances car cela peut créer des problèmes d'incompatibilité. L'erreur "Program type already present: android.support.design.widget.CoordinatorLayout$Behavior" fait partie de ces erreurs d'incompatibilité provoquées par une mise à jour de librairie.

Cette erreur peut notamment s'afficher lorsque vous mettez à jour la librairie "com.android.support:appcompat" de la version "27.0.2" vers la version "27.1.0". Dans votre fichier "build.gradle", la notation de la librairie change.

implementation 'com.android.support:appcompat-v7:27.0.2'
implementation 'com.android.support:appcompat-v7:27.1.0'

Il existe une solution qui permet de corriger le problème sans revenir en arrière sur la version de la librairie. Il est en effet généralement déconseillé de revenir en arrière dans les versions car les nouvelles versions apportent des correctifs de sécurité importants. Pour corriger cette erreur, il faut importer la librairie "com.android.support:design" avec comme version minimum la version "27.1.0".

implementation 'com.android.support:design:27.1.0'

Vous devrez relancer la construction du projet pour vérifier que l'erreur a bien disparu.

Autour du même sujet

Comment corriger l'erreur Program type already present: android.support.design.widget.CoordinatorLayout$Behavior
Comment corriger l'erreur Program type already present: android.support.design.widget.CoordinatorLayout$Behavior

La gestion des dépendances dans un projet Android est une partie importante. Il faut faire attention lorsque l'on met à jour ses dépendances car cela peut créer des problèmes d'incompatibilité. L'erreur "Program type already present:...